首页 网络技术
  1. 正文

PHP中composer报错certificate verify failed怎么办

环境: centos7

使用 composer 安装依赖的时候报错了. 出现了如下的错误描述:

Failed to download laravel/laravel from dist: The "https://files.phpcomposer.com/files/laravel/laravel/48f44440f7713d3267af2969ed84297455f3787e.zip" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failedFailed to enable cryptofailed to open stream: operation failed

是证书出现了一些问题.

尝试修复:

yum update -y

待全部软件更新后, 重启机器, 再次尝试composer 来安装依赖, 成功了

composer create-project --prefer-dist laravel/laravel vms3.0-adminInstalling laravel/laravel (v5.4.15)  - Installing laravel/laravel (v5.4.15): Downloading (100%)         Created project in vms3.0-admin> php-r "file_exists('.env') || copy('.env.example', '.env');"Loading composer repositories with package informationUpdating dependencies (including require-dev)Package operations: 59 installs, 0 updates, 0 removals  - Installing symfony/polyfill-mbstring (v1.3.0): Downloading (100%)           - Installing symfony/var-dumper (v3.2.6): Downloading (100%)

本文标题:PHP中composer报错certificate verify failed怎么办
本文链接:https://www.qqooo.cn/post/6312.html
版权说明:网站文章均来源于手工整理和网友投稿,若有不妥之处请来信 xsds@vip.qq.com 处理,谢谢!