首页 网络技术
  1. 正文

怎么用Composer安装特定版本的软件包

这是一篇关于如何使用 Composer 安装特定版本软件包的简短快速文章

TL;DR 版本

composer require vendor/package:version//Examplecomposer require laravel/passport:6.0

详细版

在终端导航到项目根目录,执行以下命令,使用 Composer 安装特定版本的包

假设您希望将 larvael/passport 包的 6.0.0 版安装到您的项目中,而不是安装最新版本。然后你应该执行以下命令

composer require laravel/passport:6.0.0

添加双引号以在版本号中使用插入符号或波浪号运算符。

例如

composer require middlewares/whoops "^0.4"

波浪号版本范围 (~) – ~1.2.3 相当于 >=1.2.3 <1.3.0

插入符号版本范围 (^) – ^1.2.3 相当于 >=1.2.3 <2.0.0

因此,使用波浪号,您将获得补丁的自动更新,但不会更新次要和主要版本。但是,如果您使用 Caret,您将获得补丁和次要版本,但不会获得主要(重大更改)版本。

Tilde Version 被认为是一种“更安全”的方法,但如果您使用可靠的依赖项(维护良好的库),则使用 Caret 版本应该不会有任何问题(因为小的更改不应该破坏更改。

本文标题:怎么用Composer安装特定版本的软件包
本文链接:https://www.qqooo.cn/post/5190.html
版权说明:网站文章均来源于手工整理和网友投稿,若有不妥之处请来信 xsds@vip.qq.com 处理,谢谢!