首页 网络技术
  1. 正文

CI框架使用composer如何安装依赖包

本文针对 Linux 系统,windows 第一步 根据 composer 官网进行安装 后面的步骤相同

step1  全局安装 composer

$ curl -sS https://getcomposer.org/installer | php$ mv composer.phar /usr/local/bin/composer

step2  创建composer.json 到你的项目根目录

{
"require": {
"kriswallsmith/buzz": "*"
}}

这里将添加一个 Buzz package, 用来处理 HTTP Request / Response PHP 5.3.x 类.

step3  执行如下命令 下载依赖包

$ composer install

之后你会注意到 composer 创建了一个 ./vendors 在你的应用目录里 而且代码也在里面.

step4 在项目中添加包的自动加载

加上下面一行在你的 index.php里

require_once './vendor/autoload.php';

需要加载在

require_once BASEPATH.'core/CodeIgniter.php';

前面

step5 测试

例子如下:

class Test extends CI_Controller{
public function index()
{
$browser = new Buzz\Browser();
$response = $browser->get('http://www.baidu.com');
echo $browser->getLastRequest()."\n";
echo $response;
}}

本文标题:CI框架使用composer如何安装依赖包
本文链接:https://www.qqooo.cn/post/5746.html
版权说明:网站文章均来源于手工整理和网友投稿,若有不妥之处请来信 xsds@vip.qq.com 处理,谢谢!