首页 网络技术
  1. 正文

composer错误Could not find package的解决方法

我正在逐步将我自己的框架提交到GITHUB上, 这真不是件容易的事情.

1.GITHUB上注册账号,开启项目

2.本地GIT clone 下来

3.本地修改代码, 提交回GITHUB

4. Packagist 上注册账号, 同步项目到Packagist

5.使用Composer 更新代码到本地另一个测试项目中,  此时出现问题

总是提示

 [InvalidArgumentException] Could not find a version of package ice-php/test-repository matching your minimum-stability (stable). Require it with an explicit version constraint allowing its desired stability.

根据这个提示,我各种修改 有关于 版本的相关东西, 仍旧无果

然后我带着版本号 Update, 即

composer require ice-php/test-repository:^1.0

此时提示为:

 [InvalidArgumentException] Could not find package ice-php/test-repository. Did you mean this?
 ice-php/test-repository

这时,我开始怀疑Composer源. 之前我将代码源修改为中国镜像服务器

https://packagist.phpcomposer.com

去除, 仍旧

今天睡足了, 神清气爽, 就琢磨这个值原来是什么?  网上查不到~,  尝试改成Packagist的地址 https://packagist.org

再运行composer, 卡住不动,  一看这个有戏.

漫长的等待后, 指定 版本 更新成功.

再尝试 无版本指定 的 ,  也成功.

注: 我现在的电脑是翻墙的, 以上操作成功.

1.墙啊~~~~

2. P用没有的百度啊~~~

本文标题:composer错误Could not find package的解决方法
本文链接:https://www.qqooo.cn/post/6245.html
版权说明:网站文章均来源于手工整理和网友投稿,若有不妥之处请来信 xsds@vip.qq.com 处理,谢谢!