首页 网络技术
  1. 正文

composer安装依赖时报错的解决方法

目录

0x01 安装时composer出现Killed,被终止

0x02 出现“Your requirements could not be resolved to an installable set of packages.”

在使用下面命令对composer.json进行安装的时候,经常会出现下面的两种种问题。

composer install

0x01 安装时composer出现Killed,被终止

情况可能是下面这个样子的

这种情况是由于缓存不足而造成的,在Linux中我们可以增加缓存来解决这个问题。

free -mmkdir -p/var/_swap_cd /var/_swap_dd if=/dev/zero of=swapfile bs=1M count=2000mkswapswapfileswapon swapfileecho "/var/_swap_/swapfile none swapsw 0 0" >> /etc/fstabfree -m

0x02 composer出现“Your requirements could not be resolved to an installable set of packages.”

这种报错的情况一般是这样子的

它虽然出现了"Your requirements could not be resolved to an installable set of packages.","You can also run php--ini inside terminal to see which files are used by PHP in CLI mode."这两种提示,但是这个不是我们所要关注的重点。

我们需要关注的是中间Problem提示了哪些内容

比如下面这个情况

在这种情况下,我们仅仅只需要安装php所对应的gd就可以解决这个报错了。

这里我用Ubuntu为例来说明,如果你安装的是php7.0的,即使用下列命令进行安装的

apt-get install php7.0

这个时候需要运行下列命令就可以安装了,就可以解决这个问题了

apt-get install php7.0-gd

下面这个例子也是一样的解决办法

apt-get install php7.0-mbstring

如果安装的是php7.2,这里改一下版本就可以了

apt-get install php7.2-mbstring

本文标题:composer安装依赖时报错的解决方法
本文链接:https://www.qqooo.cn/post/6295.html
版权说明:网站文章均来源于手工整理和网友投稿,若有不妥之处请来信 xsds@vip.qq.com 处理,谢谢!